Last updated by 5 years ago

Page: GrowlGrails, Version:2

GrowlGrails

Author: Marc Palmer http://www.anyware.co.uk

Growl is a generic but slick notification framework for OS X. This script bundle adds configurable notifications for common grails script events, so that for example you can have it automatically pop up a message when your "grails run-app" has completed, or an error has occurred while running a grails command.

It sounds lame, but actually its incredibly useful when you multi-task and let grails go and "do its thing" while you get on with something else. It also lends a welcome visual element to grails.

Requirements: Grails 0.5.5 or higher, and Growl must be installed and working.

Due to Apple discontinuing support for Cocoa-Java bridging in Java 6, GrowlGrails will not work if you are running with the 1.6 VM, you get errors about an inability to link to a libObjJava dynamic library. Either change your VM to 1.5 or uninstall growl grails. It may be possible in future to directly talk over a socket to Growl or us some custom JNI, but I can't spend the time on it any time soon.

Installation: Download GrowlGrails.zip and unzip the contents to ~/.grails so that it creates a ~/.grails/lib and ~/.grails/scripts. That's it. Now run a grails command! Go to Growl preferences pane in OS X to configure the style of notification and which events you want to be notified of.